您的位置:首页 > 其它

【洛谷 3093】[USACO13DEC]牛奶调度Milk Scheduling

2017-11-08 07:35 435 查看
题目描述

Farmer John has N cows that need to be milked (1 <= N <= 10,000), each of which takes only one unit of time to milk.

Being impatient animals, some cows will refuse to be milked if Farmer John waits too long to milk them. More specifically, cow i produces g_i gallons of milk (1 <= g_i <= 1000), but only if she is milked before a deadline at time d_i (1 <= d_i <= 10,000). Time starts at t=0, so at most x total cows can be milked prior to a deadline at time t=x.

Please help Farmer John determine the maximum amount of milk that he can obtain if he milks the cows optimally.

FJ有N(1 <= N <= 10,000)头牛要挤牛奶,每头牛需要花费1单位时间。

奶牛很厌烦等待,奶牛i在它的截止时间d_i (1 <= d_i <= 10,000)前挤g(1 <= g_i <= 1000)的奶,否则将不能挤奶。时间t开始时为0,即在时间t=x时,最多可以挤x头奶牛。

请计算FJ的最大挤奶量。

输入输出格式

输入格式:

Line 1: The value of N.

Lines 2..1+N: Line i+1 contains the integers g_i and d_i.

输出格式:

Line 1: The maximum number of gallons of milk Farmer John can obtain.

输入输出样例

输入样例#1:

4

10 3

7 5

8 1

2 1

输出样例#1:

25

说明

There are 4 cows. The first produces 10 gallons of milk if milked by time 3, and so on.

Farmer John milks cow 3 first, giving up on cow 4 since she cannot be milked by her deadline due to the conflict with cow 3. Farmer John then milks cows 1 and 2.

奇妙的贪心。跟之前的建筑抢修有区别。

根据产奶量建立一个小根堆。先按照截止时间从小到大排个序,依次放入小根堆中,每次放时间+1.如果发现当前截止时间< =t,说明放不下了,这时候从将堆顶元素的产奶量与当前元素比较。如果大于当前,则替换,保证最优。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=100000+10;
int n,sum;
struct node
{
int g,d;
}a[maxn];
bool cmp(node a,node b)
{
return a.d<b.d;
}
bool operator < (node a,node b)
{
return a.g>b.g;//小根堆
}
priority_queue<node>q;
int main()
{
int t=0;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i].g,&a[i].d);
}
sort(a+1,a+1+n,cmp);//按截止时间从小到大排序
q.push(a[1]);
sum+=a[1].g;//总产奶量
t++;
for(int i=2;i<=n;i++)
{
node f=q.top();
if(t<a[i].d)
{
q.push(a[i]);
sum+=a[i].g;
t++;
}
else if(a[i].g>f.g&&t>=a[i].d)
{
q.pop();
q.push(a[i]);
sum+=a[i].g;
sum-=f.g;
}
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: