您的位置:首页 > 其它

poj 3083 Children of the Candy Corn (dfs+bfs)

2017-11-01 20:29 417 查看
The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.

Input
Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters
each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'. 

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also
be separated by at least one wall ('#'). 

You may assume that the maze exit is always reachable from the start point.

Output
For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single
space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########


Sample Output
37 5 5
17 17 9


题意:给一个地图,问优先从向左走,和优先向右走,和最短路的步数;

解:将4个方向化成0,1,2,3  四个数来表示方向,传递当前方向,然后根据数字的相邻关系判断走的方向

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <map>
#include <queue>
#include <string>
using namespace std;
const int N = 100;
char str

;
int vis

;
int flag, n, m;
int dir[4][2]={{0,-1},{-1,0},{0,1},{1,0}};
struct node
{
int x, y, step;
};

void dfs(int x,int y,int d,int t,int step)
{
if(flag) return ;
for(int i=0;i<4;i++)
{
int a=x+dir[(d+4-i*t+t)%4][0], b=y+dir[(d+4-i*t+t)%4][1];
if(a<0||a>=n||b<0||b>=m||str[a][b]=='#') continue;
if(flag) return ;
if(str[a][b]=='E')
{
flag=step;
return ;
}
dfs(a,b,(d+4-i*t+t)%4,t,step+1);
}
return ;
}

int bfs(int s,int e)
{
queue<node>q;
node tmp;
tmp.step=0,tmp.x=s,tmp.y=e;
memset(vis,0,sizeof(vis));
vis[s][e]=1;
q.push(tmp);
while(!q.empty())
{
node u=q.front();q.pop();
for(int i=0;i<4;i++)
{
int a=u.x+dir[i][0], b=u.y+dir[i][1];
if(a<0||a>=n||b<0||b>m||vis[a][b]||str[a][b]=='#') continue;
tmp.x=a,tmp.y=b,tmp.step=u.step+1;
if(str[a][b]=='E') return tmp.step;
vis[a][b]=1;
q.push(tmp);
}
}
return -1;
}

int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int  sx, sy;
scanf("%d %d", &m, &n);
for(int i=0;i<n;i++)   scanf("%s",str[i]);
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(str[i][j]=='S') sx=i, sy=j;
}
}
flag=0;
dfs(sx,sy,0,-1,0);
int cnt1=flag;
flag=0;
dfs(sx,sy,0,1,0);
int cnt2=flag;
int cnt3=bfs(sx,sy);
printf("%d %d %d\n",cnt1+2,cnt2+2,cnt3+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: