您的位置:首页 > 运维架构

POJ 2976-Dropping tests(01分数规划)

2017-10-31 09:22 489 查看
Dropping tests

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13941 Accepted: 4874
Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be


.
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is 

. However, if you drop the third test, your cumulative average becomes 

.

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for
all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case
with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output
83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

Stanford Local 2005
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

关于01分数规划,有一篇讲的不错的博客:http://www.cnblogs.com/perseawe/archive/2012/05/03/01fsgh.html
#include<stdio.h>
#include<algorithm>
using namespace std;
int n,k,a[1005],b[1005];
double c[1005];
int check(double x)
{
double sum=0;
for(int i=0;i<n;i++)
c[i]=a[i]-x*b[i];
sort(c,c+n);
for(int i=k;i<n;i++)
sum+=c[i];
return sum>=0;
}
void work()
{
double l=0,r=1.0;
for(int i=0;i<100;i++)
{
double mid=(l+r)/2.0;
if(check(mid))
l=mid;
else
r=mid;
}
printf("%.0f\n",l*100);
}
int main(void)
{
while(scanf("%d%d",&n,&k)!=EOF)
{
if(n==k && n==0)
break;
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<n;i++)
scanf("%d",&b[i]);
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: