您的位置:首页 > 其它

POJ-2481 Cows (树状数组 入门题)

2017-10-11 12:32 253 查看
Cows

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 20178 Accepted: 6865
Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj. 

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input

The input contains multiple test cases. 

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.
Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi. 

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint

Huge input and output,scanf and printf is recommended.

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 100005
struct tree{
int l, r, id;
}a[maxn];
int ans[maxn], c[maxn];
bool mysort(tree e1, tree e2){
if(e1.l == e2.l) return e1.r > e2.r;
return e1.l < e2.l;
}
inline int lowbit(int x){
return x & (-x);
}
void add(int x){
while(x < maxn){
c[x] += 1;
x +=lowbit(x);
}
}
int query(int x){
int res = 0;
while(x){
res += c[x];
x -= lowbit(x);
}
return res;
}
int main(){
int n;
while(scanf("%d", &n) != EOF && n != 0){
memset(c, 0, sizeof(c));
for(int i = 1; i <= n; ++i){
scanf("%d %d", &a[i].l, &a[i].r);
a[i].l += 2;
a[i].r += 2;
a[i].id = i;
}
sort(a + 1, a + 1 + n, mysort);
ans[a[1].id] = 0;
add(a[1].r);
for(int i = 2; i <= n; ++i){
ans[a[i].id] = i - 1 - query(a[i].r - 1);
add(a[i].r);
}
int cur = 0;
for(int i = 2; i <= n; ++i){
if(a[i].l == a[i - 1].l && a[i].r == a[i - 1].r){
cur++;
ans[a[i].id] -= cur;
}
else cur = 0;
}
for(int i = 1; i <= n; ++i){
printf("%d%s", ans[i], i == n ? "\n" : " ");
}
}
}

/*
题意:1e5个区间,坐标范围1e5,问每个区间有多少个区间包含它。

思路:把所有区间都读进来,然后按l从小到大排序,l相等则按r从大到小排序。
这样遍历时,之前已经访问的区间的左端点一定小于等于当前区间的左端点;如果存在
已经访问的区间左端点等于当前区间的左端点,那么这些区间的右端点一定大于等于当前
区间的右端点。这样对于每个区间,我们只需要计算之前出现的区间有多少个区间的右端点比
自己的右端点大即可,计算后再将该区间的右端点插入树状数组,继续计算后面的区间。
注意处理相等的区间。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: