您的位置:首页 > 其它

POJ 2481 Cows(树状数组)

2013-09-20 21:18 351 查看
Cows

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 10546 Accepted: 3476
Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj. 

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input

The input contains multiple test cases. 

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.
Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi. 

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint

Huge input and output,scanf and printf is recommended.
Source
题意 :意思是说给你好多个点,求这个区间有多少个子区间。
分析:看起来很难解决,但是把点都画出来,就可以看到求的是一个点的左上角有多少个点。我们可以先排序。再更新。

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<algorithm>
using namespace std;
int cnt[100005];
struct Node
{
int x,y;
int in;
}node[100005];
int n;
int c[100005];
bool cmp(Node a,Node b)
{
if(a.y==b.y)
return a.x<b.x;
else
return a.y>b.y;
}
int lb(int x)
{
return x&(-x);
}
void add(int i,int val)
{
while(i<=n)
{
c[i]+=val;
i+=lb(i);
}
}
int sum(int i)
{
int s=0;
while(i>0)
{
s+=c[i];
i-=lb(i);
}
return s;
}
int main()
{
int i;
while(~scanf("%d",&n))
{
if(n==0)
break;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&node[i].x,&node[i].y);
node[i].in=i;
}
sort(node+1,node+n+1,cmp);
memset(c,0,sizeof(c));
memset(cnt,0,sizeof(cnt));
cnt[node[1].in]=0;
add(node[1].x+1,1);//x与y都有可能为0,所以都++  
for(i=2;i<=n;i++)
{
if(node[i].x==node[i-1].x&&node[i].y==node[i-1].y)

cnt[node[i].in]=cnt[node[i-1].in];
else
{
cnt[node[i].in]=sum(node[i].x+1);
}
add(node[i].x+1,1);
}
printf("%d",cnt[1]);
for(i=2;i<=n;i++)
{
printf(" %d",cnt[i]);
}
printf("\n");

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: