您的位置:首页 > 其它

面向对象程序设计上机练习四(变量引用)

2017-09-21 23:34 274 查看

Problem Description

将变量的引用作为函数形参,实现2个int型数据交换。

Input

输入2个int型整数。

Output

输出2个整数交换前后的值。

Example Input

88 66

Example Output

88 66

66 88

code

#include <iostream>
using namespace std;

void change(int c, int d)
{
cout << c << " " << d << endl;
int t;
t = c;
c = d;
d = t;
cout << c << " " << d << endl;
}

int main()
{
int a,b;
//变量引用
int &x = a;
int &y = b;
cin >> a >> b;
change(x,y);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: