您的位置:首页 > 其它

面向对象程序设计上机练习四(变量引用)

2016-09-10 17:21 190 查看


面向对象程序设计上机练习四(变量引用)

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

将变量的引用作为函数形参,实现2个int型数据交换。


Input

输入2个int型整数。


Output

输出2个整数交换前后的值。


Example Input

88 66



Example Output

88 66
66 88



Author

#include <iostream>

using namespace std;

void chance(int &x, int &y)     //引用形参
{
int t = x;
x = y;
y = t;
}

int main()
{
int x, y;
cin >> x >> y;
cout << x << " " << y << endl;
chance(x, y);
cout << x << " " << y << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: