您的位置:首页 > 理论基础 > 数据结构算法

SDUT 2117数据结构实验之链表二:逆序建立链表

2017-09-13 20:10 260 查看

数据结构实验之链表二:逆序建立链表

Time Limit: 1000MSMemory Limit: 65536KB

SubmitStatistic

Discuss

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10
11 3 5 27 9 12 43 16 84 22


Example Output

22 84 16 43 12 9 27 5 3 11


Hint

不能使用数组! 
#include<stdio.h>
#include<stdlib.h>
typedef struct NODE
{
int data;
struct NODE *next;
}Node;
int main()
{
int n,i;
scanf("%d",&n);
Node *head,*p;
head=(Node *)malloc(sizeof(Node));
head->next=NULL;
for(i=0;i<n;i++)
{
p=(Node*)malloc(sizeof(Node));
p->next=NULL;
scanf("%d",&p->data);
p->next=head->next;//关键步骤
head->next=p;//关键步骤
}
for(p=head->next;p!=NULL;p=p->next)
{
printf("%d ",p->data);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: