您的位置:首页 > 理论基础 > 数据结构算法

SDUT 2117 数据结构实验之链表二:逆序建立链表

2015-01-22 12:53 197 查看


数据结构实验之链表二:逆序建立链表




Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^



题目描述

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


输入

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。


输出

依次输出单链表所存放的数据。


示例输入

10
11 3 5 27 9 12 43 16 84 22



示例输出

22 84 16 43 12 9 27 5 3 11



提示

不能使用数组!

#include <bits/stdc++.h>

using namespace std;

struct node
{
int data;
struct node *next;
};

void setList(struct node *head,int n)
{
struct node *p;
while(n--)
{
p=(struct node *)malloc(sizeof(struct node));
cin>>p->data;
p->next=head->next;
head->next=p;
}
}

void printList(struct node *head)
{
struct node *p=head->next;
while(p)
{
if(p!=head->next)
cout<<" ";
cout<<p->data;
p=p->next;
}
cout<<endl;
}

int main()
{
ios::sync_with_stdio(false);
struct node *head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
int n;
cin>>n;
setList(head,n);
printList(head);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: