您的位置:首页 > 其它

hdu_6186_前缀后缀_水_死于英语

2017-09-12 22:02 393 查看
CS Course

Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an, and some queries.

A query only contains a positive integer p, which means you

are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.

Input

There are no more than 15 test cases.

Each test case begins with two positive integers n and p

in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤105

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤109 for each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin q lines, 1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.

Sample Input

3 3

1 1 1

1

2

3

Sample Output

1 1 0

1 1 0

1 1 0

mean:
给你a数组:
求除了第i位 外所有数 &,|,^
的值;
answer:
求前缀后缀就好


#include<bits/stdc++.h>
using namespace std;
const int N=(int) 1e5+10;
int a
,st1
,st2
,st3
,ed1
,ed2
,ed3
;
int main()
{
int n,m,i,j;
while(cin>>n>>m>>a[1])
{
st1[1]=st2[1]=st3[1]=a[1];
for(i=2;i<=n;i++)
{
scanf("%d",&a[i]);
st1[i]=st1[i-1]&a[i];
st2[i]=st2[i-1]|a[i];
st3[i]=st3[i-1]^a[i];
}
ed1
=ed2
=ed3
=a
;
for(i=n-1;i>=1;i--)
{
ed1[i]=ed1[i+1]&a[i];
ed2[i]=ed2[i+1]|a[i];
ed3[i]=ed3[i+1]^a[i];
}
while(m--)
{
int x; scanf("%d",&x);
if(x==1)
printf("%d %d %d\n",ed1[2],ed2[2],ed3[2]);
else if(x==n)
printf("%d %d %d\n",st1[n-1],st2[n-1],st3[n-1]);
else
printf("%d %d %d\n",st1[x-1]&ed1[x+1],st2[x-1]|ed2[x+1],st3[x-1]^ed3[x+1]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: