您的位置:首页 > 大数据 > 人工智能

bzoj 1664: [Usaco2006 Open]County Fair Events 参加节日庆祝(DP)

2017-09-12 17:13 453 查看

1664: [Usaco2006 Open]County Fair Events 参加节日庆祝

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 456  Solved: 321

[Submit][Status][Discuss]

Description

Farmer John has returned to the County Fair so he can attend the special events (concerts, rodeos, cooking shows, etc.). He wants to attend as many of the N (1 <= N <= 10,000)
special events as he possibly can. He's rented a bicycle so he can speed from one event to the next in absolutely no time at all (0 time units to go from one event to the next!). Given a list of the events that FJ might wish to attend, with their start times
(1 <= T <= 100,000) and their durations (1 <= L <= 100,000), determine the maximum number of events that FJ can attend. FJ never leaves an event early.
有N个节日每个节日有个开始时间,及持续时间. 牛想尽可能多的参加节日,问最多可以参加多少. 注意牛的转移速度是极快的,不花时间.

Input

* Line 1: A single integer, N.
* Lines 2..N+1: Each line contains two space-separated integers, T and L, that describe an event that FJ might attend.

Output

* Line 1: A single integer that is the maximum number of events FJ can attend.

Sample Input

7

1 6

8 6

14 5

19 2

1 8

18 3

10 6

Sample Output

4

貌似像这种线段按尾排序然后DP的题已经好多道了(第7页的)

dp[i]表示前i小时能参加的最多活动数量

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef struct Line
{
int x, y;
bool operator < (const Line &b) const
{
if(y<b.y)
return 1;
return 0;
}
}Line;
Line s[10005];
int dp[200005];
int main(void)
{
int n, i, p;
scanf("%d", &n);
for(i=1;i<=n;i++)
{
scanf("%d%d", &s[i].x, &s[i].y);
s[i].y += s[i].x-1;
}
sort(s+1, s+n+1);
p = 1;
for(i=1;i<=200000;i++)
{
dp[i] = dp[i-1];
while(s[p].y==i)
{
dp[i] = max(dp[i], dp[s[p].x-1]+1);
p++;
}
}
printf("%d\n", dp[200000]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: