您的位置:首页 > 其它

HDU 2838 Cow Sorting(树状数组)

2017-09-07 21:36 465 查看


Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3824    Accepted Submission(s): 1343


Problem Description

Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows
in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two
cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

 

Input

Line 1: A single integer: N

Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.

 

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

 

Sample Input

3
2
3
1

 

Sample Output

7

Hint
Input Details

Three cows are standing in line with respective grumpiness levels 2, 3, and 1.
Output Details

2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

 

Source

2009 Multi-University Training Contest 3 - Host by WHU

【思路】
可以知道,交换的最小值必定是脾气小的牛和脾气大的牛交换的代价总和,如果两头相邻的牛脾气相当,那么他们之间不交换。对于每一头牛,在它前面有几头脾气比它大的,就要加上多少次交换它的代价,所以首先要求逆序对的数量,其次也要知道前面脾气比它大的牛的脾气总和。所以可以按照牛的顺序读入,用两个树状数组a和s分别维护牛的只数和脾气总数,进行单点更新,区间查询。

【代码】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN=1e5+5;

int n;
long long a[MAXN],s[MAXN];

int lowbit(int x)
{
return (x&-x);
}

void modify(int x,int num)
{
int add=x*num;
while(x<MAXN){
a[x]+=num;
s[x]+=add;
x+=lowbit(x);
}
}

long long num(int x)
{
long long ans=0;
while(x>0){
ans+=a[x];
x-=lowbit(x);
}
return ans;
}

long long sum(int x)
{
long long ans=0;
while(x>0){
ans+=s[x];
x-=lowbit(x);
}
return ans;
}

int main()
{
memset(a,0,sizeof(a));
memset(s,0,sizeof(s));
scanf("%d",&n);
long long ans=0;
for(int i=1;i<=n;i++){
int x;
scanf("%d",&x);
modify(x,1);
ans+=(num(n)-num(x))*x;
ans+=(sum(n)-sum(x));
}
printf("%lld\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: