您的位置:首页 > 编程语言 > Go语言

Discovering Gold LightOJ - 1030 概率DP

2017-09-04 16:19 357 查看
You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect
6 sided dice. If you get X in the dice after throwing, you add
X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the
Nth position you stop your journey. Now you are given the information about the cave, you have to find out the
expected number of gold you can collect using the given procedure.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains
N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the
ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than
1000.

Output
For each case, print the case number and the expected number of gold you will collect. Errors less than
10-6 will be ignored.

Sample Input
3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output
Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

思路:

设从x位置到n位置的期望值为Ex,那么Ex=gold[x]+E(x+1)+E(x+2)+E(x+3)+E(x+4)+E(x+5)+E(x+6)

又因为你已经知道了E(n)=gold
,所以你只要在合理的情况下从n位置递推到1位置即可

#include<bits/stdc++.h>
using namespace std;
double dp[166];
int main()
{
int kase;
scanf("%d",&kase);
for(int t=1; t<=kase; t++)
{
int n;
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%lf",&dp[i]);
}
for(int i=n; i>=1; i--)
{
int s=min(6,n-i);
for(int j=1; j<=s; j++)
{
dp[i]+=1.0/s*dp[i+j];
}
}
printf("Case %d: %.8f\n",t,dp[1]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: