您的位置:首页 > 编程语言 > Go语言

lightoj 1030 Discovering Gold (基础概率dp)

2015-09-24 21:20 435 查看
Discovering Gold
Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu
Description

You are in a cave, a long cave! The cave can be represented by a
1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect
6 sided dice. If you get X in the dice after throwing, you add
X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the
Nth position you stop your journey. Now you are given the information about the cave, you have to find out the
expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer
N (1 ≤ N ≤ 100)
denoting the dimension of the cave. The next line contains
N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the
ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than
1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than
10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题目链接:http://lightoj.com/volume_showproblem.php?problem=1030

题目大意:一条线上n个点,每个点有不同数量的金子,每次投骰子1-6,投到几前进几步并得到对应点上的金子,如果点数超过n则继续投,直到到n为止,求得到金子数量的期望值

题目分析:很基础的概率dp,设dp[i]为从i到n所能得到的金子的期望,显然dp
= val
,然后从后往前递推,dp[i - 1] += Σdp[i] / 6,但是注意有可能加6会超过n,所以递推式应该为dp[i - 1] += Σj (1-6) dp[i] / min(6, n - i)

#include <cstdio>
#include <algorithm>
using namespace std;
int const MAX = 105;
double dp[MAX];

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
            scanf("%lf", &dp[i]);
        for(int i = n - 1; i >= 1; i--)
            for(int j = 1; j <= 6; j++)
                dp[i] += dp[i + j] / (1.0 * min(6, n - i));
        printf("Case %d: %.8f\n", ca, dp[1]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: