您的位置:首页 > 编程语言 > Go语言

[LightOJ 1030] Discovering Gold (概率DP)

2016-01-17 23:03 316 查看
Description

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect
all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information
about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer
of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

有一个1*N的格子地图,每个格子有一个权值。刚开始在1的位置上,掷骰子前进。如果前进的步数超过了地图的限制,就重掷。每到一个格子,就得到格子上的权值。在N的位置上游戏结束。问最后得分的期望。很简单的一道概率DP。

坑点在于必须倒过来DP。在接近终点的时候,转移概率会不为1/6,而起点处转移总是1/6。如果顺着DP的话,那么在起点附近,转移概率会不为1/6。

附上一份错误的转移。

dp[1]=inpt[1];
for(int i=1; i<=1; i++)
{
<span style="white-space:pre">	</span>dp[i]=inpt[i];
int base=min(i-1,6);
for(int j=1; j<=base; j++)
{
dp[i]+=dp[i-j]/base;
}
}
printf("Case %d: %.10lf\n", ck, dp
);


以下是一段蠢得不行但是AC了的代码
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
#define CLR(a) memset(a,0,sizeof(a))
const double eps=1e-6;
int N;
double inpt[110];
double dp[110];

int main()
{
int T;
scanf("%d", &T);
for(int ck=1; ck<=T; ck++)
{
CLR(dp);
CLR(inpt);
scanf("%d", &N);
for(int i=1; i<=N; i++) scanf("%lf", &inpt[i]);
dp
=inpt
;
for(int i=N; i>=1; i--)
{
dp[i]=inpt[i];
int base=min(N-i,6);
for(int j=1; j<=base; j++)
{
dp[i]+=dp[i+j]/base;
}
}
printf("Case %d: %.10lf\n", ck, dp[1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: