您的位置:首页 > 产品设计 > UI/UE

1101. Quick Sort (25)

2017-09-01 17:24 337 查看


1101. Quick Sort (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CAO, Peng

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot
to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;

3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;

2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;

and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers
in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
5
1 3 2 4 5

Sample Output:
3
1 4 5


提交代码

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#include <iomanip&g
4000
t;
#include <string>
#include <cstdio>
#include <string.h>
#include <set>
#include <cmath>
#include <map>
#include <stack>
#include <string.h>
#include <sstream>
using namespace std;
typedef long long LL;

//之前想用最普通的想法水题 但是超时
//参考 https://www.liuchuo.net/archives/1917 妹子很萌 哈哈哈
//思路是 开辟两个数组 ,如果数组a排序后的位置不变 而且 比 之前出现的数值都要大 可以证明是个pivot
int a[1000000], b[1000000];
int main() {
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int n;
cin >> n;
vector<LL> ans; //保存最后的结果
for(int i = 0; i < n; i++) {
cin >> a[i];
b[i] = a[i];
}
int max = 0;
// 超时
// 时间复杂度O(n^2)
// for(int i = 0; i < n; i++) {
// for(int j = 0; j < n; j++){
// if((j != i && j < i && v[j] > v[i]) || (j != i && j > i && v[j] < v[i])){
// flag = 0;
// break;
// }
// }
// if(flag){
// ans.push_back(v[i]);
// }
sort(a, a + n);
//时间复杂度O(n)
for(int i = 0; i < n; i++) {
if(a[i] == b[i] && b[i] > max) {
ans.push_back(b[i]);
}
if(b[i] > max){
max = b[i];
}
}
cout << ans.size() << endl;
for(int i = 0; i < ans.size(); i++) {
if(i == 0) {
cout << ans[i];
} else {
cout << " " << ans[i];
}

}
cout << endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题