您的位置:首页 > 产品设计 > UI/UE

PAT_A 1101. Quick Sort (25)

2016-10-20 23:18 441 查看

1101. Quick Sort (25)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;

3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;

2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;

and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5

1 3 2 4 5

Sample Output:

3

1 4 5

分析

这是做过的,最简单的一道,就不分析。注意,如果输出0(no pivot),还需要再次输出一次回车。

code

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
bool big(int a,int b)
{
return a>b;
}
int main()
{
vector<int> d;
vector<int> l;//填充最大值
vector<int> r;//填充最小值
d.push_back(0);
l.push_back(0);
r.push_back(0);
int n=0;
cin>>n;
int tmp;
for(int i=1;i<=n;i++)
{
cin>>tmp;
d.push_back(tmp);
r.push_back(tmp);
l.push_back(tmp);
if(l[i-1]>tmp)
l[i]=l[i-1];
}
vector<int> o;
for(int i=n;i>0;i--)
{
if(r[i-1]>r[i])
r[i-1]=r[i];
if(l[i]<=r[i])
o.push_back(d[i]);
}
cout<<o.size()<<endl;
sort(o.begin(),o.begin()+o.size(),big);
for(int i=o.size()-1;i>=0;i--)
{
cout<<o[i];
if(i==0)
cout<<endl;
else
cout<<" ";
}
if(o.size()==0)
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PATA