您的位置:首页 > 其它

ccpc预选赛-1003Friend-Graph

2017-08-20 12:09 295 查看

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6514    Accepted Submission(s): 1610


[align=left]Problem Description[/align]
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.

In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.

A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

 

[align=left]Input[/align]
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)

The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000)

Then there are n-1 rows. The ith
row should contain n-i numbers, in which number aij
represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

 

[align=left]Output[/align]
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

 

[align=left]Sample Input[/align]

1
4
1 1 0
0 0
1

 

[align=left]Sample Output[/align]
[align=left]Great Team!
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]刚开始想算法想优化想了很久然后发现直接硬搜就好了。。。。[/align]
[align=left]不过不能开3000*3000的数组,内存会炸[/align]
#include<cstdio>
#include<cstring>
int a[1500][3000],b[3010],c[3010];
int main(){
int t,n,i,j,k,p,r;
scanf("%d",&t);
while(t--){
scanf("%d",&n);memset(a,0,sizeof(a));
for(i=1;i<=n;i++){
for(j=i+1;j<=n;j++){
if(i<1500)scanf("%d",&a[i][j]);
else scanf("%d",&a[3000-i][3000-j]);
}
}
int flag=0,x,y;
if(n<=2){
printf("Great Team!\n");continue;
}
if(n==3)if(a[1][2]&&a[1][3]&&a[2][3]){
printf("Great Team!\n");continue;
}
for(i=1;i<n;i++){
k=0;p=0;
if(i<1500)
for(j=i+1;j<=n;j++){
if(a[i][j])b[k++]=j;else c[p++]=j;
}
else
for(j=i+1;j<=n;j++){
if(a[3000-i][3000-j])b[k++]=j;else c[p++]=j;
}
for(j=0;j<k;j++){
for(r=j+1;r<k;r++){
if(b[j]<1500)x=b[j],y=b[r];
else x=3000-b[j],y=3000-b[r];
if(a[x][y]){flag++;break;}
}
if(flag)break;
}
if(flag)break;
for(j=0;j<p;j++){
for(r=j+1;r<p;r++){
if(b[j]<1500)x=c[j],y=c[r];
else x=3000-c[j],y=3000-c[r];
if(a[x][y]==0){flag++;break;}
}
if(flag)break;
}
if(flag)break;
}
if(flag)printf("Bad Team!\n");
else printf("Great Team!\n");
}
}


[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ccpc- 1003Friend-Graph