您的位置:首页 > 理论基础 > 计算机网络

2017ccpc网络赛 1003Friend-Graph

2017-08-20 12:17 387 查看

Friend-Graph

[b]Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 781    Accepted Submission(s): 412
[/b]

[align=left]Problem Description[/align]
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.

In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.

A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

 

[align=left]Input[/align]
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)

The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000)

Then there are n-1 rows. The ith
row should contain n-i numbers, in which number aij
represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

 

[align=left]Output[/align]
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

 

[align=left]Sample Input[/align]

1
4
1 1 0
0 0
1

 

[align=left]Sample Output[/align]

Great Team!

 签到题,建立map,循环遍历找朋友
#include <stdio.h>
int map[3001][3001];
int main(int argc, char *argv[])
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int i,j;
int a;
for(i=0;i<n-1;i++)
{
for(j=i+1;j<n;j++)
{
int a;
scanf("%d",&a);
map[i][j]=map[j][i]=a;
}
}
int flag=0;
for(i=0;i<n;i++)
{
int sum1=0,sum2=0;
for(j=0;j<n;j++)
{
if(map[i][j]==1)
sum1++;
else
sum2++;
if(sum1>=3||sum2>=3)
{
flag=1;
break;
}
}
if(flag==1)
break;
}
if(flag==1)
printf("Bad Team!\n");
else
printf("Great Team!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: