您的位置:首页 > 产品设计 > UI/UE

Double Queue - POJ 3481 - 树堆Treap的数组实现

2017-08-19 23:27 399 查看

链接:

  http://poj.org/problem?id=3481

题目:

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

QueryOperation
0The system needs to stop serving
1 K PAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list
Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2

1 20 14

1 30 3

2

1 10 99

3

2

2

0

Sample Output

0

20

30

10

0

题意:

  每次将顾客K以P的优先级加入队列中,然后询问你当前优先级最大的顾客或者是优先级最小的顾客。

思路:

  很直观的一个题啊,也可以用map来实现。写的时候有一个地方写崩了,然后就疯狂调试,有一些函数我记得是没用的,但现在也忘了,就统统贴上来吧…

实现:

#include <iostream>
#include <algorithm>
#include <set>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <iomanip>
#include <functional>
#include <sstream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>

#define read read()
#define edl putchar('\n')
#define clr(a, b) memset(a,b,sizeof a)

using namespace std;
const int maxn = 1e7;

struct treap {
int v, info, fix, ch[2], size;

treap() {}

treap(int info, int v) : info(info), v(v) {
ch[0] = ch[1] = -1;
fix = rand();
size = 1;
}

int compare(int x) {
if (v == x) return -1;
return x < v ? 0 : 1;
}
} node[maxn];

int root, tot;

void Maintain(int t) {
node[t].size = 1;
if (node[t].ch[0] != -1) node[t].size += node[node[t].ch[0]].size;
if (node[t].ch[1] != -1) node[t].size += node[node[t].ch[1]].size;
}

void Rotate(int &t, int d) {
if (t == -1) return;
int tmp = node[t].ch[d ^ 1];
node[t].ch[d ^ 1] = node[tmp].ch[d];
node[tmp].ch[d] = t;
Maintain(t);
Maintain(tmp);
t = tmp;
}

void Insert(int &t, int info, int v) {
if (t == -1) {
t = ++tot;
node[t] = treap(info, v);
} else {
//int d = node[t].compare(v);
int d = v < node[t].v ? 0 : 1;
Insert(node[t].ch[d], info, v);
if (node[t].fix < node[node[t].ch[d]].fix) Rotate(t, d ^ 1);
}
Maintain(t);
}

int Find(int t, int v) {
if (t == -1) return t;
int d = node[t].compare(v);
if (d == -1) return t;
return Find(node[t].ch[d], v);
}

int Findmax(int t) {
if (t == -1) return -1;
while (node[t].ch[1] != -1) {
t = node[t].ch[1];
}
return t;
}

int Findmin(int t) {
if (t == -1) return -1;
while (node[t].ch[0] != -1) {
t = node[t].ch[0];
}
return t;
}

void Delete(int &t) {
if (node[t].ch[0] != -1 && node[t].ch[1] != -1) {
int d = node[node[t].ch[0]].fix < node[node[t].ch[1]].fix ? 0 : 1;
Rotate(t, d);
Delete(node[t].ch[d]);
} else {
if (node[t].ch[0] == -1) t = node[t].ch[1];
else t = node[t].ch[0];
}
if (t != -1) Maintain(t);
}

void D
e932
elete(int &t, int x) {
if (t == -1) return;
int k = node[t].compare(x);
if (k == -1) {
if (node[t].ch[0] != -1 && node[t].ch[1] != -1) {
int d = node[node[t].ch[0]].fix < node[node[t].ch[1]].fix ? 0 : 1;
Rotate(t, d);
Delete(node[t].ch[d]);
} else {
if (node[t].ch[0] == -1) t = node[t].ch[1];
else t = node[t].ch[0];
}
} else Delete(node[t].ch[k], x);
if (t != -1) Maintain(t);
}

void Print(int t) {
if (t == -1) return;
Print(node[t].ch[0]);
cout << node[t].v << ' ';
Print(node[t].ch[1]);
}

void insert(int info, int v) {
Insert(root, info, v);
}

void remove(int &t) {
//Delete(t);
Delete(root, t);
}

int findmax() {
return Findmax(root);
}

int findmin() {
return Findmin(root);
}

void print() {
Print(root);
}

int main() {
ios_base::sync_with_stdio(false);
cin.tie(0);
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
#endif

/*
int a;
while(~scanf("%d",&a))
t.insert(a,a);
t.print();
cout << '\n';
int tmp = t.findmax();
//t.remove(tmp);
t.print();
cout << '\n';
t.remove(t.node[t.findmax()].v);
t.print();
*/
int q, info, v;
root = -1, tot = 0;
while (~scanf("%d", &q)) {
if (q == 0) break;
if (q == 1) {
scanf("%d%d", &info, &v);
insert(info, v);
} else if (q == 2) {
int tmp = findmax();
if (tmp == -1) {
puts("0");
continue;
}
printf("%d\n", node[tmp].info);
remove(node[tmp].v);
} else {
int tmp = findmin();
if (tmp == -1) {
puts("0");
continue;
}
printf("%d\n", node[tmp].info);
remove(node[tmp].v);
}
//t.print();
//cout << '\n';
}
return 0;
}


附上用STL实现的版本:

#include <bits/stdc++.h>
using namespace std;
int main() {
int q, info, v;
map<int, int> mp;
map<int, int>::iterator it;
while(scanf("%d",&q), q) {
if(q == 1) {
scanf("%d%d", &info, &v);
mp[v] = info;
} else if(q == 2) {
if(mp.size() == 0) puts("0");
else {
it = --mp.end();
printf("%d\n",it->second);
mp.erase(it);
}
} else {
if(mp.size() == 0) puts("0");
else {
it = mp.begin();
printf("%d\n",it->second);
mp.erase(it);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息