您的位置:首页 > 其它

POJ 3928 Ping pong【树状数组经典难点实现】PS

2013-03-12 14:29 387 查看
原题链接:http://poj.org/problem?id=3928

我的链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=20357#problem/A

Ping pong

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1215 Accepted: 452
Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee
among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are
lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different,
we call two games different. Now is the problem: how many different games can be held in this ping pong street?
Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 

Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).
Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input
1
3 1 2 3

Sample Output
1

Source

Beijing 2008
//Accepted	792 KB	219 ms	C++	912 B	2013-03-12 14:19:33
#include<cstdio>
#include<cstring>

const int maxn = 20000 + 10;
const int Max = 100000 + 10;

int a[maxn];
/*
*c[i] 从左到右记录a[1]到a[i-1]中比a[i]小的
*d[i] 从右到左扫描记录a
到a[i]比 a[i] 小的
*/
int c[maxn], d[maxn];
/*
*x[j] 表示目前为止扫描过的所有a[i] 中,
*是否存在一个 a[i] == j (x[j] = 0表示不存在, x[j] = 1 表示存在)
*则 c[i] 就是前缀和 x[1] + x[2] + x[a[i]-1]
*同理算出 d[i]
*/
int x[Max];

int lowbit(int x)
{
return (x & -x);
}

int sum(int k)
{
int ret = 0;
while(k > 0)
{
ret += x[k];
k -= lowbit(k);
}
return ret;
}

void add(int k, int d)
{
while(k <= Max)
{
x[k] += d;
k += lowbit(k);
}
}
int main()
{
int T;
int n;
scanf("%d", &T);
while(T--)
{
__int64 ans = 0;
scanf("%d", &n);
for(int i = 1; i <= n; i++)
scanf("%d", &a[i]);

memset(c, 0, sizeof(c));
memset(x, 0, sizeof(x)); /* 预处理 */
for(int i = 1; i <= n; i++)
{
add(a[i], 1);
c[i] = sum(a[i]-1);
}

memset(d, 0, sizeof(d));
memset(x, 0, sizeof(x)); /* 预处理 */
for(int i = n; i >= 1; i--)
{
add(a[i], 1);
d[i] = sum(a[i]-1);
}

for(int i = 2; i < n; i++)
ans += c[i]*(n-i-d[i]) + (i-c[i]-1)*d[i];
printf("%I64d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: