您的位置:首页 > 其它

HDU 1061-Rightmost Digit

2017-08-11 10:46 423 查看


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57573    Accepted Submission(s): 21800


Problem Description

Given a positive integer N, you should output the most right digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2

3

4

 

Sample Output

7

6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

简单的快速幂取模题。

#include <iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
#define LL long long
int main()
{
int T;
LL N,k,ans;
scanf("%d",&T);
while(T--)
{
scanf("%lld",&N);
k=1;
ans=N;
while(N!=0)
{
if(N&1)
k=(k*ans)%10;
ans=(ans*ans)%10;
N>>=1;
}
printf("%lld\n",k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: