您的位置:首页 > 大数据 > 人工智能

2017 Multi-University Training Contest - Team 5 1006 Rikka with Graph

2017-08-09 11:31 483 查看

Rikka with Graph

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 386    Accepted Submission(s): 247
[/align]

[align=left]Problem Description[/align]

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G
with n
nodes and m
edges, we can define the distance between (i,j)
(dist(i,j))
as the length of the shortest path between i
and j.
The length of a path is equal to the number of the edges on it. Specially, if there are no path betweeni
and j,
we make dist(i,j)
equal to n.

Then, we can define the weight of the graph G
(wG)
as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n
nodes, and he wants to choose no more than m
pairs of nodes (i,j)(i≠j)
and then link edges between each pair. In this way, he can get an undirected graphG
with n
nodes and no more than m
edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).
 

[align=left]Input[/align]

The first line contains a numbert(1≤t≤10),
the number of the testcases.

For each testcase, the first line contains two numbers
n,m(1≤n≤106,1≤m≤1012).
 

[align=left]Output[/align]

For each testcase, print a single line with a single number -- the answer.
 

[align=left]Sample Input[/align]

1
4 5

 

[align=left]Sample Output[/align]

14

 

官方题解:

考虑贪心地一条一条边添加进去。

当 m≤n−1时,我们需要最小化距离为 n 的点对数,所以肯定是连出一个大小为 m+1的联通块,剩下的点都是孤立点。

在这个联通块中,为了最小化内部的距离和,肯定是连成一个菊花的形状,即一个点和剩下所有点直接相邻。

当 m>n−1时,肯定先用最开始 n−1条边连成一个菊花,这时任意两点之间距离的最大值是 2

因此剩下的每一条边唯一的作用就是将一对点的距离缩减为1。

这样我们就能知道了最终图的形状了,稍加计算就能得到答案。要注意m 有可能大于 n(n−1)/2

题目大意:给你两个数字n,m分别代表的是有多少点多少边,每个边的长度为1,现在让你求m条边构成的图中,所有的点相连所需要的长度和最小

解题思路:找规律,发现m在不同的范围内,所求的答案有不同的公式表示,每两个点之间共有n*(n-1)/2种可能

如果m大于等于这个数就直接为n*(n-1),如果少于它则一个边一个边的进行拆除,每拆一个边就增加2

然后到一个临界点为m=n-1一个点分别连其他的点可以根据上一个算出,当m小于这个数的时候就分为孤立的点了,

有一部分相连,就和上一种情况一样然后分联通的,孤立的,联通的与孤立的分别计算。

/* ***********************************************
┆  ┏┓   ┏┓ ┆
┆┏┛┻━━━┛┻┓ ┆
┆┃       ┃ ┆
┆┃   ━   ┃ ┆
┆┃ ┳┛ ┗┳ ┃ ┆
┆┃       ┃ ┆
┆┃   ┻   ┃ ┆
┆┗━┓ 马 ┏━┛ ┆
┆  ┃ 勒 ┃  ┆      
┆  ┃ 戈 ┗━━━┓ ┆
┆  ┃ 壁     ┣┓┆
┆  ┃ 的草泥马  ┏┛┆
┆  ┗┓┓┏━┳┓┏┛ ┆
┆   ┃┫┫ ┃┫┫ ┆
┆   ┗┻┛ ┗┻┛ ┆
************************************************ */
#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int main()
{
int t;
scanf("%d", &t);
while (t--)
{
long long n, m, p, q;
scanf("%lld%lld", &n, &m);
long long ans = 0;
int flag = 0;
if (m > n * (n - 1) / 2) ///在这个范围内代表每两个点之间都可以一步连到所以为n*(n-1)
{
printf("%lld\n", n * (n - 1));
flag = 1;
}
else if (m >= n - 1 && m <= n * (n - 1) / 2) ///在这个范围内与m为n*(n-1)/2相比每少一条边就减少2
{
ans += ((n * (n - 1) / 2) - m) * 2 + n * (n - 1);
}
else                    ///这个范围内分为孤立的点与连在一起的点,分三块计算
{
p = m + 1;
q = n - m - 1;
ans += q * p * n * 2 + q * (q - 1) * n + (p - 1) * (p - 1) * 2;
}
if (flag == 0)
{
printf("%lld\n", ans);
}
}
}

/************************************************
┆  ┏┓   ┏┓ ┆
┆┏┛┻━━━┛┻┓ ┆
┆┃       ┃ ┆
┆┃   ━   ┃ ┆
┆┃ ┳┛ ┗┳ ┃ ┆
┆┃       ┃ ┆
┆┃   ┻   ┃ ┆
┆┗━┓    ┏━┛ ┆
┆  ┃    ┃  ┆      
┆  ┃    ┗━━━┓ ┆
┆  ┃  AC代马   ┣┓┆
┆  ┃           ┏┛┆
┆  ┗┓┓┏━┳┓┏┛ ┆
┆   ┃┫┫ ┃┫┫ ┆
┆   ┗┻┛ ┗┻┛ ┆
************************************************ */
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 多校
相关文章推荐