您的位置:首页 > 其它

HDU - 1025 Constructing Roads In JGShining's Kingdom(最长单调子序列 nlogn)

2017-08-09 10:35 369 查看


Constructing Roads In JGShining's Kingdom

Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor
cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

 

Output

For each test case, output the result in the form of sample. 

You should tell JGShining what's the maximal number of road(s) can be built. 

 

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

 

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint
Huge input, scanf is recommended.

 

题意:很纯的最长单调不下降子序列,不过要用nlogn的算法

解题思路:学习了nlogn的方法,怎么感觉比n^2的算法还要好理解……dp[i]存的是以i为最长上升子序列长度时,最后那个数的最小值。对于每一个数,我们只要找到dp数组里刚好比那个数大的那个数的位置,就是那个最长上升子序列的长度了,然后更新它的最小值。然后dp数组里存的肯定是有序上升的序列,因此可以采用二分查找。

#include<iostream>
#include<memory.h>
#include<string>
#include<algorithm>
#define INF 1<<29
using namespace std;
const int MAXN=500005;
int N;
int dp[MAXN];

struct node{
int p;
int r;
}list[MAXN];

bool cmp(node a,node b){
return a.p<b.p;
}

int main(){

int t=1;
while(~scanf("%d",&N)){
for(int i=0;i<N;i++)
scanf("%d%d",&list[i].p,&list[i].r);
sort(list,list+N,cmp);

for(int i=0;i<MAXN;i++)
dp[i]=INF;

for(int i=0;i<N;i++)
*lower_bound(dp,dp+N,list[i].r)=list[i].r;

int len=lower_bound(dp,dp+N,INF)-dp;

if(len==1)
printf("Case %d:\nMy king, at most %d road can be built.\n\n",t++,len);
else
printf("Case %d:\nMy king, at most %d roads can be built.\n\n",t++,len);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐