您的位置:首页 > 其它

Sudoku 数独问题(dfs)

2017-08-05 00:24 357 查看
[align=left]Problem Description[/align]
Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is
to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.



 

[align=left]Input[/align]
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this
line. If a cell is empty it is represented by 0.
 

[align=left]Output[/align]
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
 

[align=left]Sample Input[/align]

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

 

[align=left]Sample Output[/align]

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

#if 0
#include<iostream>
using namespace std;
int a[15][15],cnt;
bool flag=0;

int ok(int x,int y,int k)
{
for(int i=0; i<9; i++)
{
if(a[x][i]==k)
return 0;
if(a[i][y]==k)
return 0;
}

int sx=x-x%3;
int sy=y-y%3;
for(int i=sx; i<sx+3; i++)
{
for(int j=sy; j<sy+3; j++)
{
if(a[i][j]==k)
return 0;
}
}
return 1;
}

void dfs(int num)
{

bool flag1=0;
int x,y;

if(num==cnt)
{
for(int i=0; i<9; i++)
{
for(int j=0; j<9; j++)
{
cout<<a[i][j];
}
cout<<endl;
}
flag=1;
return;
}
if(flag)
return;

for(int i=0; i<9; i++)
{
for(int j=0; j<9; j++)
{
if(a[i][j]==0)
{
flag1=1;
x=i;y=j;
break;
}
}
if(flag1)
break;
}

for(int k=1; k<=9; k++)
{
if(ok(x,y,k))
{
a[x][y]=k;
dfs(num+1);
a[x][y]=0;
}

}
}

int main()
{
int N;
char c;
cin>>N;

while(N--)
{
flag=0;
cnt=0;

for(int i=0; i<9; i++)
{
for(int j=0; j<9; j++)
{
cin>>c;
a[i][j]=c-'0';
if(a[i][j]==0)
cnt++;
}
}

dfs(0);

}

}
#endif
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: