您的位置:首页 > 其它

HDU - 5655 CA Loves Stick(竟有四边形判定定理。。。)

2017-08-03 14:56 225 查看
CA loves to play with sticks. 

One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral. 

(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
InputFirst line contains TT denoting
the number of testcases. 
TT testcases
follow. Each testcase contains four integers a,b,c,da,b,c,d in
a line, denoting the length of sticks. 
1≤T≤1000, 0≤a,b,c,d≤ 263−11≤T≤1000, 0≤a,b,c,d≤263−1
OutputFor each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
Sample Input
2
1 1 1 1
1 1 9 2


Sample Output
Yes
No


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5655

题意:判断能否组成四边形。

quadrilateral
英[ˌkwɒdrɪˈlætərəl]美[ˌkwɑ:drɪˈlætərəl]
adj.四边(形)的;
n.四边形;
[例句]Isoparametric element of arbitrary quadrilateral plays
an important role in finite element analysis.

等参数任意四边形单元在有限元分析中有着重要的作用。
一:不知道这个单词的意思,不会看懂题的。

二:知道这个题什么意思,不一定知道有这么一个定理,判断四边形。

(a<=b<=c<=d)    d<a+b+c;

三:知道前两点也要让你错几次!!!。数据太坑了。。2^63-1,把人往死里坑



我用的是d-b-c<a.稍不注意就会数据崩溃。

还要注意0!!!

#include<stdio.h>
#include<algorithm>
using namespace std;
__int64 a[5];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int f=0;
for(int i=0; i<4; i++)
{
scanf("%I64d",&a[i]);
if(a[i]==0)f=1;
}
if(f)
{
printf("No\n");
continue;
}
sort(a,a+4);
if(a[3]-a[2]-a[1]<a[0])
{
printf("Yes\n");
}
else printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: