您的位置:首页 > 其它

hdu 5655 CA Loves Stick【思维】

2016-04-03 09:02 495 查看

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 328    Accepted Submission(s): 116


[align=left]Problem Description[/align]
CA loves to play with sticks.

One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.

(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)  

[align=left]Input[/align]
First line contains T
denoting the number of testcases.
T
testcases follow. Each testcase contains four integers
a,b,c,d
in a line, denoting the length of sticks.
1≤T≤1000, 0≤a,b,c,d≤263−1
 

[align=left]Output[/align]
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 
Sample Input

2

1 1 1 1

1 1 9 2

 

Sample Output

Yes

No
 

四边形简单判断定理:a+b+c>d。如果有0的边当然不行。

问题关键所在于爆long long int,每一个值都是在long long int的数据边缘,所以我们需要改变式子为:

a>d-b-c,就能解决爆的问题。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
long long int a[5];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
for(int i=0;i<4;i++)
{
scanf("%I64d",&a[i]);
}
sort(a,a+4);
if(a[0]==0)printf("No\n");
else
{
if(a[3]-a[0]-a[1]<a[2])
{
printf("Yes\n");
}
else
printf("No\n");
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 5655