您的位置:首页 > 其它

8.3 C - 这是水题3

2017-08-03 09:18 183 查看


                                      C - 这是水题3





The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so
the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some
way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would
connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the
villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village
label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road
followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network
will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every
possible set of roads will not finish within the one minute time limit.

Sample Input
9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output
216

30

题意:先输入一个数字n,接下来n-1行数据,每行第一个数据表示城市代号,第二个数据m表示有m个城市与这个城市相连,接下来有m*2个数据,表示与该城市相连的城市和相距的距离,例如数据:A 2 B 12 I 25,表示城市A能和其他2个城市相连,这两个分别是B和I,距离分别是12和15,求出将所有城市连通的最小距离。






#include<stdio.h>
#include<string.h>
int a[1000][1000],book[1000],d[1000];
int main()
{
int i,j,k,m,n,c,m1;
int sum,min,max=1e9;
char s[5],s1[5];
int t1,t2,t3,t4;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
getchar();
memset(a,0,sizeof(a));
memset(book,0,sizeof(book));
memset(d,0,sizeof(d));//初始化数据
for(i=1;i<=900;i++)
{
for(j=1;j<=900;j++)
{
if(i==j)
{
a[i][j]=0;
}
else
{
a[i][j]=max;
}
}
}//初始化数组a

for(i=1;i<n;i++)
{
scanf("%s%d",&s,&m);//读入每一行前两个数据
t1=s[0]-'A'+1;
for(j=1;j<=m;j++)
{
scanf("%s%d",&s1,&m1);
t2=s1[0]-'A'+1;
a[t1][t2]=m1;
a[t2][t1]=m1;//将连通情况正反存储到数组
}
}

for(i=1;i<=n;i++)
{
d[i]=a[1][i];
}
book[1]=1;
c=0;
c++;
sum=0;
while(c<n)//Prim核心算法
{
min=max;
for(i=1;i<=n;i++)
{
if(book[i]==0&&d[i]<min)
{
j=i;
min=d[i];
}
}
sum+=d[j];
book[j]=1;
c++;
for(i=1;i<=n;i++)
{
if(book[i]==0&&d[i]>a[j][i])
{
d[i]=a[j][i];
}
}
}
printf("%d\n",sum);

}
return 0;
}




 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: