您的位置:首页 > 其它

杭电2700 水题。。水过

2014-08-05 10:49 148 查看

                                           Parity

                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

                                                           Total Submission(s): 2286    Accepted Submission(s): 1783


[align=left]Problem Description[/align]
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of

0's does not affect the parity of a bit string.
 

[align=left]Input[/align]
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase
letter 'o'.

 

[align=left]Output[/align]
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the
letter was 'o').
 

[align=left]Sample Input[/align]

101e
010010o
1e
000e
110100101o
#

 

[align=left]Sample Output[/align]

1010
0100101
11
0000
1101001010 题意弄懂就好做了 题意:将前面的数字相加,再判断,o代表奇数,e代表偶数,若判断正确,最后一位数改为0,否则唯1;
 <span style="BACKGROUND-COLOR: #ffff99">ac代码</span>
#include<stdio.h>
#include<string.h>
int main()
{
 char n,i,str[1000],le;
 while(~scanf("%s",str),str[0]!='#')
 {
  int sum=0;
  le=strlen(str);
  for(i=0;i<le-1;i++)
  sum+=str[i]-'0';
  if((sum&1&&str[le-1]=='o')||(!(sum&1)&&str[le-1]=='e'))
    str[le-1]='0' ;
  else
    str[le-1]='1';
  for(i=0;i<le;i++)
  printf("%c",str[i]);
  printf("\n");
 }
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 水题 2700