您的位置:首页 > 其它

[kuangbin带你飞]专题二 搜索进阶 E

2017-08-01 19:10 246 查看
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.



For example, given “ACGT”,”ATGC”,”CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.

Input

The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.

Output

For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.

Sample Input

1

4

ACGT

ATGC

CGTT

CAGT

Sample Output

8

这道题是对退出DFS的判断问题,首先要判断一下最长的有多长,然后当

这个节点对所有的DNA都没有贡献时就退出,这里用到了迭代加深搜索,就是我每一次搜索都指定一个最大搜索长度,如果大于这个搜索长度就退出,然后再深入一层,防止无限次的加深搜索

#include<bits/stdc++.h>
using namespace std;
#define bug cout<<"This is a BUG!"<<endl;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int n,deep,ans=-1;
char s[10][10];
int size[10];

char cnt[5]={'A','T','C','G'};

void dfs(int num,int len[]) {
int sum=0;
if(ans!=-1||num>deep) return;
for(int i=0;i<n;i++) sum=max(sum,size[i]-len[i]);
if(num+sum>deep) return ;
if(sum==0) {ans=num;return ;}
for(int i=0;i<4;i++) {
int flag=0;
int tlen[10]={0};
for(int j=0;j<n;j++) {
if(s[j][len[j]]==cnt[i]) {
tlen[j]=len[j]+1;
flag++;
}
else tlen[j]=len[j];
}
if(flag>0)
dfs(num+1,tlen);
}
return ;
}

int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
int T;
cin>>T;
for(int k=0;k<T;k++) {
ans=-1,deep=0;
cin>>n;
memset(s,0,sizeof(s));
for(int i=0;i<n;i++) {
cin>>s[i];
size[i]=strlen(s[i]);
deep=max(deep,size[i]);
}
int len[10]={0};
while(1) {
dfs(0,len);
if(ans!=-1) break;
deep++;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: