您的位置:首页 > 其它

Birthday Paradox ||生日悖论

2017-07-31 20:58 453 查看
题目来源HPUACM暑期培训:https://vjudge.net/contest/174968#problem/H

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.


Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.


Output

For each case, print the case number and the desired result.


Sample Input

2

365

669


Sample Output

Case 1: 22

Case 2: 30


先说一下生日悖论的内容,生日悖论(Birthday paradox)是指,如果一个房间里有23个或23个以上的人,那么至少有两个人的生日相同的概率要大于50%。这就意味着在一个典型的标准小学班级(30人)中,存在两人生日相同的可能性更高。对于60或者更多的人,这种概率要大于99%。从引起逻辑矛盾的角度来说生日悖论并不是一种悖论,从这个数学事实与一般直觉相抵触的意义上,它才称得上是一个悖论。大多数人会认为,23人中有2人生日相同的概率应该远远小于50%。

这儿有更清楚的解释:http://wiki.mbalib.com/wiki/%E7%94%9F%E6%97%A5%E6%82%96%E8%AE%BA

懂了生日悖论后题就简单了

计算对立事件即可:

1 - (n-1)/ n - ( n - 2 ) / n ….(n-k)/n

#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int main()
{
int N,n,c=1,a;
double p,t;
scanf("%d",&N);
while(N--)
{
p=1.0;
t=0;
scanf("%d",&n);
a=0;
while(t<0.5)//大于0.5既符合题目要求,不再计算
{
a++;
p*=(n-a)*1.0/n;//计算
t=1-p;
}
printf("Case %d: %d\n",c++,a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: