您的位置:首页 > 其它

PAT 1043. Is It a Binary Search Tree (25)

2017-07-28 11:00 363 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case
4000
, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11

Sample Output 1:
YES
5 7 6 8 11 10 8

Sample Input 2:
7
8 10 11 8 6 7 5

Sample Output 2:
YES
11 8 10 7 5 6 8

Sample Input 3:
7
8 6 8 5 10 9 11

Sample Output 3:
NO

#include "iostream"
using namespace std;
int cnt;
bool isBST(int a[], int l, int r) {
int k = l + 1;
int mid = l;
if (l < r) {
while (a[k] < a[l]) {
mid = k;
k++;
if (k > r)
break;
}
for (; k <= r; k++) {
if (a[k] < a[l]) {
return 0;
}
}
if (mid == l || mid == r)
return isBST(a, l+1, r);
else
return isBST(a, l + 1, mid) && isBST(a, mid + 1, r);
}
if (l == r)
return 1;
}
bool isMirrorBST(int a[], int l, int r) {
int k = l + 1;
int mid = l;
if (l < r) {
while (a[k] >= a[l]) {
mid = k;
k++;
if (k > r)
break;
}
for (; k <= r; k++) {
if (a[k] >= a[l]) {
return 0;
}
}
if (mid == l || mid == r)
return isMirrorBST(a, l + 1, r);
else
return isMirrorBST(a, l + 1, mid) && isMirrorBST(a, mid + 1, r);
}
if (l == r)
return 1;
}

void getPostOrderFromPreOrder(int a[],int l,int r) {
int k = l + 1;
int mid = l;
if (l < r) {
while (a[k] < a[l]) {
mid = k;
k++;
if (k > r)
break;
}
if(mid == l || mid ==r)
getPostOrderFromPreOrder(a, l + 1, r);
if (mid != l&&mid != r) {
getPostOrderFromPreOrder(a, l + 1, mid);
getPostOrderFromPreOrder(a, mid + 1, r);
}

}
if (cnt == 1) {
cout << a[l];
cnt++;
}
else
cout << " " << a[l];
}

void getPostOrderFromPreOrder1(int a[], int l, int r) {
int k = l + 1;
int mid = l;
if (l < r) {
while (a[k] >= a[l]) {
mid = k;
k++;
if (k > r)
break;
}
if (mid == l || mid==r)
getPostOrderFromPreOrder1(a, l + 1, r);
if (mid != l && mid!= r) {
getPostOrderFromPreOrder1(a, l + 1, mid);
getPostOrderFromPreOrder1(a, mid + 1, r);
}
}
if (cnt == 1) {
cout << a[l];
cnt++;
}
else
cout << " " << a[l];
}
int main() {
int n;
int a[1002];
cin >> n;
for (int i = 0; i < n; i++)
cin >> a[i];
bool flag1 = isBST(a, 0, n - 1);
bool flag2 = isMirrorBST(a, 0, n - 1);
bool flag = flag1 || flag2;
if (flag) {
cout << "YES" << endl;
if (flag1) {
cnt = 1;
getPostOrderFromPreOrder(a, 0, n - 1);
}
else if (flag2) {
cnt = 1;
getPostOrderFromPreOrder1(a, 0, n - 1);
}
cout << endl;
}
else
cout << "NO" << endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: