您的位置:首页 > 其它

Pat(A) 1069. The Black Hole of Numbers (20)

2017-08-18 00:11 495 查看

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1069

1069. The Black Hole of Numbers (20)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

7641 - 1467 = 6174

… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题报告

题目是找出所有的数字黑洞。

需要注意的是输出顺序以及本身就是特殊数字的情况。

代码

#include "stdio.h"
#include <algorithm>
#include <vector>
using namespace std;
int big(int num){
vector<int> arr;
arr.push_back(num / 1000);
arr.push_back(num / 100 % 10);
arr.push_back(num / 10 % 10);
arr.push_back(num % 10);
sort(arr.begin(),arr.end());
return arr[3] * 1000 + arr[2] * 100 + arr[1] * 10 + arr[0];
}

int small(int num){
vector<int> arr;
arr.push_back(num / 1000);
arr.push_back(num / 100 % 10);
arr.push_back(num / 10 % 10);
arr.push_back(num % 10);
sort(arr.begin(),arr.end());
return arr[0] * 1000 + arr[1] * 100 + arr[2] * 10 + arr[3];
}

int main(){
int num = 0;
scanf("%d",&num);
int b = big(num);
int s = small(num);
int newnum = b - s;
if (num == newnum)
printf("%04d - %04d = %04d\n",b,s,newnum);
while(num != newnum){
printf("%04d - %04d = %04d\n",b,s,newnum);
num = newnum;
b = big(num);
s = small(num);
newnum = b - s;
}
//system("pause");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: