您的位置:首页 > 移动开发

POJ 3321 Apple Tree (树状数组)

2017-07-21 19:59 417 查看
Apple Tree

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29881 Accepted: 8902
Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are
there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?



Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.

The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.

The next line contains an integer M (M ≤ 100,000).

The following M lines each contain a message which is either

"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.

or

"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x

Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.
Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output
3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题目大意:

可以更改苹果的有无,计算第N个子树上的苹果总数。

思路:

点修改计算数字和,复杂度爆炸所以思考用树状数组优化(hhhh,因为开的就是树状数组专题,不用树状数组才怪) 关键是如何把整个树弄到数组上。 思考后序遍历,发现如果按照后序遍历dfs整棵树,然后按照编号出度顺序构成数组可以比较好地满足题目中求子树数字和的要求,所以选择使用后序遍历,然后模拟一下就知道后续遍历时应该减去些什么。记录下应该减去的到时候减去就是结果了。。C++跑的算是贼鸡儿快,很开心。

代码:

#include<cstdio>
#include <cmath>
#include <vector>
#include <complex>
#include<cstdlib>
#include<string.h>
#include <iostream>
#include <algorithm>
#define	MAX 100100

int arr[MAX], hash[MAX], top, bro[MAX];
bool oc[MAX];

struct node{
int nxt, t;
}edge[MAX];

int head[MAX], inde;

void fresh(){
inde = 0;
top = 1;
memset(head, -1, sizeof(head));
}

void addedge(int s, int t){
edge[inde].t = t;
edge[inde].nxt = head[s];
head[s] = inde++;
}

void dfs(int n, int jp){
int i = head
, lst = jp;
while(i >= 0){
dfs(edge[i].t, lst);
lst = edge[i].t;
i = edge[i].nxt;
}
bro
= jp;
hash
= top++;
}

inline int lowbit(int n){
return n & (-n);
}

void update(int x, int n){
while(x < MAX){
arr[x] += n;
x += lowbit(x);
}
}

int get(int x){
int res = 0;
while(x > 0){
res += arr[x];
x -= lowbit(x);
}
return res;
}

int main()
{
int num, i, s, t, tmp;
char ord;
scanf("%d", &num);
memset(oc, 0, sizeof(oc));
fresh();
for(i = 1; i < num; i++){
scanf("%d%d", &s, &t);
addedge(s, t);
oc[t] = 1;
}
for(i = 1; oc[i]; i++);
dfs(i, 0);
for(i = 1; i <= num; i++){
update(hash[i], 1);
}
scanf("%d", &num);
memset(oc, 1, sizeof(oc));

for(i = 0; i < num; i++){
getchar();
scanf("%c", &ord);
if(ord == 'Q'){
scanf("%d", &tmp);
printf("%d\n", get(hash[tmp]) - get(hash[bro[tmp]]));

}
else{
scanf("%d", &tmp);
if(oc[tmp]) t = -1;
else t = 1;
update(hash[tmp], t);
oc[tmp] = !oc[tmp];

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: