您的位置:首页 > 大数据 > 人工智能

HDU - 4810 Wall Painting(组合数学)

2017-07-16 17:01 357 查看
传送门


Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3133    Accepted Submission(s): 1023


Problem Description

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix
them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.

When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will
get with

 different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.

Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?

You should tell Mr.Fang the answer from the first day to the n-th day.

 

Input

There are several test cases, please process till EOF.

For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

 

Output

For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

 

Sample Input

4
1 2 10 1

 

Sample Output

14 36 30 8

 

Source

2013ACM/ICPC亚洲区南京站现场赛——题目重现

 

Recommend

liuyiding

题意:给你n和k,求分别从n个中选择k个异或和

思路:首先知道0和1异或是不会影响结果的,只有1和1异或且1的个数是奇数的时候才会对结果产生影响,所以我们把每个数都转换成二进制,统计每一位上的1的个数,利用组合数学解决

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (100000+10)
#define MAXM (50000000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000003
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int num[40];
int mod=1000003;
LL C[1010][1010];

void getC()
{
for(int i = 0; i <= 1000; i++)
C[i][0] = 1;
for(int i = 1; i <= 1000; i++)
for(int j = 1; j <= i; j++)
C[i][j] = (C[i-1][j] + C[i-1][j-1]) % MOD;

}
//LL p[100050],a[65];
LL Pow(LL a, LL b)
{
LL ans = 1;
for (; b; b >>= 1, a = a * a % mod)
if (b & 1) ans = ans * a % mod;
return ans;
}

//Pow(x,mod-2) x的逆元。 - - 又被喷了的嘛
/*LL C(LL n,LL m)
{
LL ans=1LL*p
*Pow(p[m],mod-2)%mod*Pow(p[n-m],mod-2)%mod;
return ans;
}
*/
int main()
{
int i;
getC();
// for (p[0]=i=1;i<=2000;i++) p[i]=1ll*p[i-1]*i%mod;
int n;
while(Ri(n) != EOF)
{
CLR(num, 0);
for(int i = 1; i <= n; i++)
{
LL a; Rl(a);
for(int j = 0; j <= 35; j++)
if(a & (1LL<<j))
num[j]++;
}
for(int i = 1; i <= n; i++)
{
LL cnt = 0;
for(int j = 0; j <= 35; j++)//第j位的1
{
if(num[j] == 0) continue;
for(int k = 1; k <= i && k <= num[j]; k+=2)//选k个1 k为奇数时异或才加
{
if(n-num[j] >= i-k)
{
//cout<<n-num[j]<<" "<<i-k<<endl;
cnt += C[num[j]][k] * ((1LL<<j) % MOD) % MOD * C[n-num[j]][i-k] % MOD;
// cnt+=C(num[j],k)%mod*C(n-num[j],i-k)%mod*((1LL<<j)%mod)%mod;
cnt %= MOD;
}
}
}
if(i > 1)
printf(" ");
printf("%lld", cnt);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: