您的位置:首页 > 其它

动态规划:HDU1087-Super Jumping! Jumping! Jumping!(最大上升子序列和)

2017-07-05 09:35 302 查看

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24374    Accepted Submission(s): 10740


[align=left]Problem Description[/align]
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print the maximum according to rules, and one line one case.

 

[align=left]Sample Input[/align]

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

[align=left]Sample Output[/align]

4
10
3


解题心得:
1、就是求一个最长上升子序列的和,子序列不一定要相邻,这个动态规划可以先看前三项,dp[1] = num[1],这是num[2]如果大于num[1],dp[2] = dp[1] + num[2],否则dp[2] = num[2],在看第三个num[3],如果num[3]大于num[2]那么dp[3]
= dp[2] + num[3],如果num[3]大于num[1],dp[3] = dp[1] + num[3],如果num[3]不大于num[2]同时也不大于num[1],dp[3] = num[3]。说了这么多其实就是一个意思,用之前的每一个数和当前的数比较,比当前数小的就加上dp【之前数】,不然就等于当前数。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1010;
long long num[maxn];
long long dp[maxn];
void pre_num(int n)
{
memset(dp,0,sizeof(dp));
num[0] = 0;
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
}

void get_ans(int n)
{
long long Max = -1;
for(int i=1;i<=n;i++)
{
for(int j=0;j<=i;j++)
{
if(num[j] < num[i])
dp[i] = max(dp[i],dp[j]+num[i]);//之前数比当前数小,就加上当前数到之前数的和上面
}
dp[i] = max(dp[i],num[i]);//之前数都不比当前数小的情况下直接就是当前数
if(dp[i] > Max)//记录最大的那个和
Max = dp[i];
}

printf("%lld\n",Max);
}
int main()
{
int n;
while(scanf("%d",&n) && n)
{
pre_num(n);
get_ans(n);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐