您的位置:首页 > 其它

HDU1492 The number of divisors(约数) about Humble Numbers【约数】

2017-06-21 06:23 288 查看

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4105    Accepted Submission(s): 2012


[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

 

[align=left]Output[/align]
For each test case, output its divisor number, one line per case.

 

[align=left]Sample Input[/align]

4
12
0

 

[align=left]Sample Output[/align]

3
6

 

[align=left]Author[/align]
lcy
 

[align=left]Source[/align]
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛

问题链接HDU1492 The number of divisors(约数) about Humble Numbers

问题简述:参见上文。

问题分析

计算谦虚数的约数数量问题。

根据题意,1是谦虚数;谦虚数是2,3,5和7的倍数;最小的谦虚数乘以2,3,5和7是谦虚数。

需要注意的是,谦虚数约数个数是2,3,5和7的指数的乘积。

程序说明:(略)
参考链接:(略)

题记:(略)

AC的C++语言程序如下:

/* HDU1492 The number of divisors(约数) about Humble Numbers */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 4;
int divisors
= {2, 3, 5, 7};

int main()
{
long long n;

while(scanf("%lld", &n) != EOF && n) {
long long ans = 1;
for(int i=0; i<N; i++) {
int ecount = 0;
while(n % divisors[i] == 0) {
ecount++;
n /= divisors[i];
}
ans *= ecount + 1;
}

printf("%lld\n", ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐