您的位置:首页 > 运维架构 > 网站架构

shareSDK的初步使用(shareSDK中微信、qq等兼容问题,以及cocoapods支持架构冲突问题的解决)

2017-06-15 20:39 921 查看
第一次使用shareSDK来做第三方分享,可是。昨天一天都是在调试bug,一直错误不断!先说下我的开发环境:xcode:5.1真机调试:iPhone5s我们都知道xcode5.1以后開始是支持arm64的,而shareSDK中的微信、qq是不支持armv64的,所以网上都有非常多方法都是正确的改变xcode的编译条件,改成armv7,armv7s;详细怎么改我就不多说了,报错直接Google一下就知道了。关键是这个问题攻克了,问题又来了我有的开源库管理工具cocoapods来实现的安装第三方工具的(不支持的直接copy进来),结果就报错:lPod 。。。。。什么错误等,说是我用pod 导入的第三方库中的一些类符号找不到!怎么可能呢。没增加shareSDK前,什么都是好好地,怎么又出来个问题呢?结果一查原来cocoapods是默认支持条件是arm64的,所以和我们的shareSDK就冲突了,那该怎样攻克了!!网上有个方法看着说的不错。我就照着做了:链家在这里。。。引用:***************************************************************************************開始************************************************************************************************

解决cocoapods在64位iOS7系统以下的警告问题

如今编写iOS程序,引用到第三方包。运用cocoapods进行包管理已经成为了一个趋势了,可是近期运用cocoapods构建的应用却在64bit的iOS7系统中有警告的产生,详细的警告信息如以下所看到的:
Pods was rejected as an implicit dependency for ‘libPods.a’ because its architectures ‘i386’ didn’t contain all required architectures ‘x86_64’
详细的解决方式例如以下:在TAGETS =》 Build Settings 中又一次设置值.Architectures: Standard architectures (armv7, armv7s)Base SDK: Latest iOS (iOS 7.0)Build Active Architecture Only: YESSupported Platforms: iOSValid Architectures: arm64 armv7 armv7s自己的project和Podsproject都须要进行上述的设置.注意:在每次Podfile更新之后。还须要又一次检查新的Podsproject中的设置是不是如上面设置的一致。假设不一致,则须要改动一致。引用:***************************************************************************************结束************************************************************************************************我依照上面的一步步做了结果还是错,搞不懂。一看表都晚上8点了,肚子也饿了,赶紧回家吧。。。。。。。。。。今天早起一来。本来打算再换一家第三方分享sdk的。(网上有非常多:比方友盟、百度社会分享组件等)。昨天付出那么多努力。有些不死心,就在试最后一次吧,结果又找到一个收索结果俺这来做:点击打开链接在podfile的结尾加上:以下代码
post_install do |installer|  installer.project.targets.each do |target|    target.build_configurations.each do |config|      config.build_settings['ARCHS'] = "armv7s armv7"    end  endend
clean,又一次编译执行。问题奇妙的解决啦啦啦啦。。。。。。。。。。。。好高兴!!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐