您的位置:首页 > 其它

HDU 1025 Constructing Roads In JGShining's Kingdom(最长递增子序列)

2017-05-20 20:44 357 查看


Constructing Roads In JGShining's Kingdom


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 15   Accepted Submission(s) : 11


Font: Times New Roman | Verdana | Georgia


Font Size: ← →


Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor
cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^


Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.


Output

For each test case, output the result in the form of sample. 

You should tell JGShining what's the maximal number of road(s) can be built. 


Sample Input

2
1 2
2 1
3
1 2
2 3
3 1



Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.



Hint

Huge input, scanf is recommended.


Author

JGShining(极光炫影)

point:

这是一题裸的最长递增子序列,但是要控制好输出格式。PE了好多次。格式题目里没有多提(或者我瞎),是每组输出后都要跟一个空行。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long
int a[502000];
int main()
{
int n;
int p=0;
while(~scanf("%d",&n))
{
p++;
int b=n;
while(b--)
{
int x;
scanf("%d",&x);
scanf("%d",&a[x]);
}
int now[502000];
memset(now,0,sizeof now);
int cnt=1;
now[1]=a[1];
for(int i=2; i<=n; i++)
{
if(a[i]>now[cnt])
{
cnt++;
now[cnt]=a[i];
}
else
{
int k=lower_bound(now,now+cnt,a[i])-now;
now[k]=a[i];

e8ae
}
}
//if(p!=1) printf("\n");
if(cnt==1) printf("Case %d:\nMy king, at most %d road can be built.\n\n",p,cnt);
else  printf("Case %d:\nMy king, at most %d roads can be built.\n\n",p,cnt);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐