您的位置:首页 > 编程语言 > C语言/C++

POJ 1459-Power Network(网络流-最大流-ISAP)C++

2017-05-09 17:01 477 查看

Power Network

时间限制: 1 Sec 内存限制: 128 MB

题目描述

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

给n个发电站,给np个消耗站,再给nc个转发点。
发电站只发电,消耗站只消耗电,转发点只是转发电,再给m个传送线的传电能力。
问你消耗站能获得的最多电是多少。

输入

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

输出

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

样例输入

2 1 1 2
(0,1)20 (1,0)10
(0)15 (1)20
7 2 3 13
(0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5

(0)5 (1)2 (3)2 (4)1 (5)4

样例输出

15
6

提示

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

[b]题解:[/b]

[b]不必多说,裸的网络流-最大流,用的是ISAP,AC代码如下:[/b]

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<stack>
#include<ctime>
#include<vector>
using namespace std;
int n,m,in,out,maxflow;
int chu[1001],ru[1001];
struct node
{
int next,to,dis;
}edge[30001];
int head[1001],size=1;
int read()
{
int ans=0,f=1;
char i=getchar();
while(i<'0'||i>'9'){if(i=='-')f=-1;i=getchar();}
while(i>='0'&&i<='9'){ans=ans*10+i-'0';i=getchar();}
return ans*f;
}
void insert(int from,int to,int dis)
{
size++;
edge[size].next=head[from];
edge[size].to=to;
edge[size].dis=dis;
head[from]=size;
}

void putin(int from,int to,int dis)
{
insert(from,to,dis);
insert(to,from,0);
}
int dist[1001],numbs[1001];
void bfs(int src,int des)
{
int i;
for(i=0;i<=n+1;i++){dist[i]=n+2;numbs[i]=0;}
dist[des]=0;
numbs[0]=1;
int q[1001],top=0,tail=0;
q[tail++]=des;
while(top!=tail)
{
int x=q[top++];
for(i=head[x];i!=-1;i=edge[i].next)
{
int y=edge[i].to;
if(edge[i].dis==0&&dist[y]==n+2)
{
dist[y]=dist[x]+1;
numbs[dist[y]]++;
q[tail++]=y;
}
}
}
}
int dfs(int root,int flow,int des)
{
if(root==des)return flow;
int res=0,mindist=n+2;
for(int i=head[root];i!=-1;i=edge[i].next)
{
if(edge[i].dis>0)
{
int y=edge[i].to;
if(dist[root]==dist[y]+1)
{
int tmp=dfs(y,min(flow-res,edge[i].dis),des);
edge[i].dis-=tmp;
edge[i^1].dis+=tmp;
res+=tmp;
if(dist
>=n+2)return res;
if(res==flow)break;
}
mindist=min(mindist,dist[y]+1);
}
}
if(!res)
{
if(!(--numbs[dist[root]]))dist
=n+2;
++numbs[dist[root]=mindist];
}
return res;
}
int ISAP(int src,int des)
{
bfs(src,des);
int f=0;
while(dist[src]<n+2)
f+=dfs(src,2e8,des);
return f;
}
int main()
{
int i,j;
while(scanf("%d",&n)!=EOF)
{
size=1;
memset(head,-1,sizeof(head));
out=read();in=read();m=read();
for(i=1;i<=m;i++)
{
int from,to,dis;
char ch=getchar();
while(ch!='(')ch=getchar();
scanf("%d,%d)%d",&from,&to,&dis);
putin(from,to,dis);
}
for(i=1;i<=out;i++)
{
int dis;
char ch=getchar();
while(ch!='(')ch=getchar();
scanf("%d)%d",&chu[i],&dis);
putin(n,chu[i],dis);
}
for(i=1;i<=in;i++)
{
int dis;
char ch=getchar();
while(ch!='(')ch=getchar();
scanf("%d)%d",&ru[i],&dis);
putin(ru[i],n+1,dis);
}
maxflow=0;
maxflow=ISAP(n,n+1);
printf("%d\n",maxflow);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: