您的位置:首页 > 其它

POJ - 2376 Cleaning Shifts(区间覆盖/贪心)

2017-04-27 21:27 351 查看
问题描述

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10


Sample Output

2


分析

典型的区间覆盖问题:

首先先结构体排序。

然后用s表示为已经覆盖的左端点,e表示为已经覆盖的右端点,在剩下所有区间内找到左端点小于等于当前已经覆盖到的区域的右端点的区间,取右端点最大的区间加入,更新s和e,直到覆盖全部的区域。

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 25000+10;
int N, T;
struct Cow{
int start, end;
}cows[maxn];

int cmp(const Cow &a, const Cow &b)
{
if(a.start < b.start) return 1;
else if(a.start == b.start && a.end < b.end) return 1;
else return 0;
}

int main()
{
scanf("%d%d",&N, &T);
for(int i=0; i<N; i++)
{
scanf("%d%d",&cows[i].start, &cows[i].end);
}
sort(cows, cows+N, cmp);
int count = 0;
int e = 0;
int index = 0;
int ok = 1;
while(e < T)
{
int s = e + 1;
for (int i = index; i < N; i++)
{
if (cows[i].start <= s)
{
//能够覆盖起始点
if (cows[i].end >= s)
{
e = max(e, cows[i].end);
}
}
else
{
//需要换头牛
index = i;
break;
}
}
if(s > e)
{
ok = 0;
break;
}
else{
count++;
}
}
if(ok) printf("%d\n",count);
else printf("-1\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: