您的位置:首页 > 其它

每日三题-Day1-C(HDU 1069 Monkey and Banana 最大有序子序列和)

2017-04-19 20:10 609 查看
原题地址

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14290 Accepted Submission(s): 7514

[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:

给你n个长方体,并给出长宽高。

如果下面的长方体的长比上面一个长方体的长要长,宽比上面一个长方体的宽要宽,则它们可以叠在一起。一个长方体可以有无限个。

每一种长方体都可以有3种摆放姿态,三个面分别作为底面摆放。

解题思路:

每个长方体分三种姿势存三次,并且每个长方体的底面的长要比宽大。

每次读入长宽高的时候,先排序。a>=b>=c

block[i].x=a;block[i].y=b;block[i].z=c;

block[i].x=a;block[i].y=c;block[i].z=b;

block[i].x=b;block[i].y=c;block[i].z=a;

结构体block[i]有五个变量,x,y,z,area,maxh,area为底面面积,maxh为以该方块为最顶层的方块塔的最大高度。

首先将结构体按area排序,其次按x排序。

block[i].maxh = max( block[0~i-1].maxh ) + block[i].z;

其中,0~i-1 内的方块中,必须满足底面长大于block[i]的底面长,宽大于block[i]的底面宽,才参与比较。

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;

struct node
{
int x,y,z,maxh,area;
} nodes[111];

int cmp(node a,node b)
{
if(a.area==b.area)
return a.x>b.x;
else
return a.area>b.area;
}

int edge[5];
int main()
{
int n;
int cake=1;
while(~scanf("%d",&n))
{
if(n==0) break;
int p=0;
for(int i=0; i<n; i++)
{
scanf("%d%d%d",&edge[0],&edge[1],&edge[2]);
sort(edge,edge+3);
nodes[p].x=edge[2];
nodes[p].y=edge[1];
nodes[p].z=edge[0];
nodes[p].area=nodes[p].x*nodes[p].y;
p++;
nodes[p].x=edge[2];
nodes[p].y=edge[0];
nodes[p].z=edge[1];
nodes[p].area=nodes[p].x*nodes[p].y;
p++;
nodes[p].x=edge[1];
nodes[p].y=edge[0];
nodes[p].z=edge[2];
nodes[p].area=nodes[p].x*nodes[p].y;
p++;

}
sort(nodes,nodes+p,cmp);

nodes[0].maxh=nodes[0].z;
int ans=0;
for(int i=0;i<3*n;i++)
{
nodes[i].maxh=0;
for(int j=0;j<i;j++)
{
if(nodes[i].x<nodes[j].x&&nodes[i].y<nodes[j].y)
{
nodes[i].maxh=max(nodes[i].maxh,nodes[j].maxh);
}
}
nodes[i].maxh+=nodes[i].z;
ans=max(nodes[i].maxh,ans);
}
printf("Case %d: maximum height = %d\n",cake++,ans);

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息