您的位置:首页 > 大数据 > 人工智能

Easier Done Than Said?

2017-04-18 20:30 295 查看

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13088    Accepted Submission(s): 6312


[align=left]Problem Description[/align]
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a
hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

 

[align=left]Input[/align]
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only
of lowercase letters.

 

[align=left]Output[/align]
For each password, output whether or not it is acceptable, using the precise format shown in the example.

 

[align=left]Sample Input[/align]

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

 

[align=left]Sample Output[/align]

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

 
/*
分类:
来源:
思路:
We are giants.
create by Lee_SD on 2017/4/
*/
#include<queue>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdio.h>
using namespace std;

int main(){
char a[10010];
while(scanf("%s",a)!=EOF){
if(strcmp(a,"end")==0)
break;
int flag2=0,have=0;
int xx,yy;
for(int i=0;i<strlen(a);i++){
if(a[i]=='a'||a[i]=='e'||a[i]=='o'||a[i]=='i'||a[i]=='u'){
have=1;xx++;yy=0;
}
else{
yy++;
xx=0;
}

if(xx>=3||yy>=3)
flag2=1;

if(i!=0){
if(a[i]==a[i-1]&&a[i]!='e'&&a[i]!='o')
flag2=1;
}
}
if(have==0)
flag2=1;

if(flag2)
printf("<%s> is not acceptable.\n",a);
else
printf("<%s> is acceptable.\n",a);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: