您的位置:首页 > 其它

poj 1837 Balance(DP)

2017-03-26 23:11 239 查看
题目链接:http://poj.org/problem?id=1837

Balance

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14310 Accepted: 9004
Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 

It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25.
Gigel may droop any weight of any hook but he is forced to use all the weights. 

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 

It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 

• the next line contains C integer numbers (these numbers are also distinct and sorted in asc
cc36
ending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis
(when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the
hook is attached: '-' for the left arm and '+' for the right arm); 

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8

Sample Output
2

Source

Romania OI 2002
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

题意:有一个天平,天平左右两边各有若干个钩子,总共有C个钩子,有G个钩码,求将钩码全部挂到钩子上使天平平衡的方法的总数。 其中可以把天枰看做一个以x轴0点作为平衡点的横轴

解析:定义一个 状态数组dp[i][j],意为在挂满前i个钩码时,平衡度为j的挂法的数量。 由于距离c[i]的范围是-15~15,钩码重量的范围是1~25,钩码数量最大是20 因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为j=15*20*25=7500。原则上就应该有dp[ 1~20 ][-7500 ~ 7500 ]。 因此为了不让下标出现负数,做一个处理,使使得数组开为 dp[1~20][0~15000],则当j=7500时天枰为平衡状态, 状态方程dp[i][ j+ w[i]*c[k]
]= ∑(dp[i-1][j])

借鉴博客:http://blog.csdn.net/lyy289065406/article/details/6648094/

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#define N 15009
using namespace std;
const int INF = 0x3f3f3f3f;

int dp[29]
;

int main()
{
int c, g, C[29], G[29];
scanf("%d%d", &c, &g);
for(int i = 0; i < c; i++) scanf("%d", &C[i]);
for(int i = 0; i < g; i++) scanf("%d", &G[i]);
memset(dp, 0, sizeof(dp));
dp[0][7500] = 1;
for(int i = 1; i <= g; i++)
{
for(int j = 0; j < N; j++)
{
if(dp[i - 1][j])
{
for(int k = 0; k < c; k++)
{
dp[i][j + C[k]*G[i-1]] += dp[i - 1][j];
}
}
}
}
printf("%d\n", dp[g][7500]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: