您的位置:首页 > 其它

《ACM程序设计》书中题目 R - 18 半素数

2017-03-16 17:14 176 查看
Description

Prime Number Definition 

An integer greater than one is called a prime number if its only positive divisors (factors) are one and itself. For instance, 2, 11, 67, 89 are prime numbers but 8, 20, 27 are not.

Semi-Prime Number Definition 

An integer greater than one is called a semi-prime number if it can be decompounded to TWO prime numbers. For example, 6 is a semi-prime number but 12 is not.

Your task is just to determinate whether a given number is a semi-prime number.

Input

There are several test cases in the input. Each case contains a single integer N (2 <= N <= 1,000,000)

Output

One line with a single integer for each case. If the number is a semi-prime number, then output "Yes", otherwise "No".

Sample Input

3

4

6

12

Sample Output

No 

Yes 

Yes 

No 

    这道题的基本题意为输入一个数,判断这个数是否为半素数(可以分解成两个素数相乘的数称为半素数)。

    基本思路为先判断可以被这个数整除的数是否为素数,然后再判断商是否为素数,如果都为素数,则这个数为半素数。



源代码如下:

#include<bits/stdc++.h>

using namespace std;

int main()

{
int n,i,j,m,h;
while(cin>>n)
{ if(n==2||n==3)h=0;
 else { h=0;
       for(i=2;i<=n/2;++i)
       {
if(n%i==0)
        {m=n/i;
         h=1;
         for(j=2;i>2&&j<i;++j)
         if(i%j==0)h=0;
         for(j=2;m>2&&j<m;++j)
         if(m%j==0)h=0;
        }
      }
     }
 if(h)cout<<"Yes"<<endl;
 else cout<<"No"<<endl;
}






    需要特别考虑n=2跟n=3的情况,还有找除数的循环用i<=n/2即可,没有必要循环到n。

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: