您的位置:首页 > 其它

POJ3624 - Charm Bracelet - 动态规划之01背包

2017-03-11 20:59 344 查看
1.题目描述:

Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37185 Accepted: 16254
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1
≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

Source

USACO 2007 December Silver
[Submit]   [Go Back]   [Status]  
[Discuss]
2.题意概述:
就是01背包,重量w,价值d

4.AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define N 4040
#define maxn 13000
using namespace std;
int w
, d
, dp[maxn];

int main()
{
int n, m;
while (scanf("%d%d", &n, &m) != EOF)
{
memset(dp, 0, sizeof(dp));
for (int i = 0; i < n; i++)
scanf("%d%d", &w[i], &d[i]);
for (int i = 0; i < n; i++)
{
for (int j = m; j >= w[i]; j--)
{
dp[j] = max(dp[j], dp[j - w[i]] + d[i]);
}
}
printf("%d\n", dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 算法 poj