您的位置:首页 > 其它

poj 3624 Charm Bracelet DP 0/1 背包问题

2014-03-02 23:17 441 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 19193Accepted: 8739
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1
≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

Source

USACO 2007 December Silver

Source Code

Problem: 3624		
Memory: 220K		Time: 235MS
Language: C++		Result: Accepted
Source Code
#include <cstdio>
#include <cstring>

const int N = 3402+1, M = 12880+1;

//int dp
[M];
int dp[M];
int w
, v
;
int n, m;

int max(int a, int b)
{
	return a>b?a:b;
}

int main()
{
//	freopen("in.txt","r",stdin);
	int n, m;
	while(scanf("%d %d", &n, &m)==2)
	{
		for(int i =1; i <= n; i++)
		{
			scanf("%d %d", &w[i], &v[i]);
		}
		//memset(dp, 0, sizeof(dp));
		int i, j;
		for(i=1; i <= n; i++)
		{
		/*	for( j=0; j <= m; j++)
			{
				if(w[i] <= j)
					dp[i][j] = max(dp[i-1][j], 
							dp[i-1][j-w[i]]+v[i]);
				else 
					dp[i][j] = dp[i-1][j];
			}*/
			for(j=m; j-w[i]>=0; j--)
				dp[j]=max(dp[j], dp[j-w[i]]+v[i]);
		}
		//printf("%d\n", dp
[m]);
		printf("%d\n", dp[m]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: