您的位置:首页 > 其它

HPUOJ---2017寒假训练--专题3/A-Til the Cows Come Home(最短路-dijkstra)

2017-03-03 18:20 429 查看


A - Til the Cows Come Home

 

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100


Sample Output
90


Hint
INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
#include<cstdio>
#define MAX 999999999
int dp[1111][1111];
int dis[1111];
int vis[1111];
int T,N,st,ed;
int min(int a,int b)
{
return (a<b)?a:b;
}
void init()
{
for(int i=1;i<=N;i++)
{
dis[i]=MAX;
vis[i]=0;
for(int j=1;j<=N;j++)
dp[i][j]=dp[j][i]=MAX;
}
}
void dijkstra()
{
dis[st]=0;
while(1)
{
int v=-1;
for(int i=1;i<=N;i++)
{
if(!vis[i]&&(v==-1||dis[i]<dis[v]))
v=i;
}
if(v==-1)
break;
vis[v]=1;
for(int i=1;i<=N;i++)
{
if(dis[i]>(dis[v]+dp[v][i]))
dis[i]=dis[v]+dp[v][i];
}
}
}
int main()
{
scanf("%d%d",&T,&N);
init();
while(T--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
dp[a][b]=dp[b][a]=min(c,dp[a][b]);
}
st=1;
ed=N;
dijkstra();
printf("%d\n",dis[ed]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: