您的位置:首页 > 其它

HDU1535~Invitation Cards(spfa+邻接表反转)

2017-02-28 14:41 253 查看


Invitation Cards

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3849    Accepted Submission(s): 1779


Problem Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information
and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special
course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number
of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which
is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 

 

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 

 

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

 

Sample Output

46
210

 

Source

Central Europe 1998

 

Recommend

LL
题目的大致意思是,每个站点都有一个志愿者,从起始点出发,先把每一个志愿者都送到目的地,然后再把每一个志愿者都接回起始点,每次只能接一人,由于数据过大,果断排除了floyd和dijkstra,然后选择了SPFA,关键点在于反向存图,代码如下
#include <iostream>
#include <iomanip>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<stdlib.h>
#include<queue>
#include<math.h>
#include<algorithm>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
const int L = 10000000+10;
const int inf = 15000000000;
using namespace std;
struct node
{
int now,to,w;
}e[L];
int n,m,
long long sum;
int first[L],go[L];
int vis[L];
long long dis[L];
void init()
{

for(int i=0;i<=m;i++)
first[i]=go[i]=-1;
for(int i=0;i<m;i++)
{

scanf("%d%d%d",&e[i].now,&e[i].to,&e[i].w);
go[i]=first[e[i].now];
first[e[i].now]=i;
}
}
void spfa(int x,int flag)
{
for(int i=0;i<=n;i++)
vis[i]=0;
for(int i=0;i<=n;i++)
dis[i]=inf;
dis[x]=0;
queue<int>q;
q.push(x);
while(!q.empty())
{
int a=q.front();
q.pop();
vis[a]=0;
for(int j=first[a];j!=-1;j=go[j])
{
int to=(flag?e[j].to:e[j].now);
if(dis[to]>dis[a]+e[j].w)
{
dis[to]=dis[a]+e[j].w;
if(!vis[to])
{
q.push(to);
vis[to]=1;
}
}
}
}
}
void init2()
{
for(int i=0;i<=m;i++)
first[i]=go[i]=-1;
for(int i=0;i<m;i++)
{
int to=e[i].to;
go[i]=first[to];
first[to]=i;
}
}
int main()
{
int s;
scanf("%d",&s);
while(s--)
{
sum=0;
scanf("%d%d",&n,&m);
init();
spfa(1,1);
for(int i=2;i<=n;i++)
sum+=dis[i];
init2();//重置地图,反向存储
spfa(1,0);
for(int i=2;i<=n;i++)
sum+=dis[i];
printf("%lld\n",sum);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: