您的位置:首页 > 其它

hdu1535 spfa

2013-04-08 16:31 309 查看


Invitation Cards

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1202 Accepted Submission(s): 520



Problem Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information
and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special
course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number
of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which
is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50


Sample Output

46
210


Source

Central Europe 1998

Recommend

LL

两次spfa+一次重新建图即可
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define inf 99999999
using namespace std;
int first[1000005];
int next[1000005];
struct node
{
int u,v,w;
};
node e[1000005];
bool inq[1000005];
int d[1000005];
int p;
int qq;
void spfa1(int u)
{
int i;
for(i=0;i<=p;i++)
d[i]=inf;
d[u]=0;
memset(inq,0,sizeof(inq));
queue<int> q;
q.push(u);
while(!q.empty())
{
u=q.front();
q.pop();
inq[u]=false;
int k;
for(k=first[u];k!=-1;k=next[k])
{
int v=e[k].v;
if(d[v]>d[u]+e[k].w)
{
d[v]=d[u]+e[k].w;
if(!inq[v])
{
inq[v]=true;
q.push(v);
}
}
}
}
}
void spfa2(int u)
{
int i;
for(i=0;i<=p;i++)
d[i]=inf;
d[u]=0;
memset(inq,0,sizeof(inq));
queue<int> q;
q.push(u);
while(!q.empty())
{
u=q.front();
q.pop();
inq[u]=false;
int k;
for(k=first[u];k!=-1;k=next[k])
{
int v=e[k].u;
if(d[v]>d[u]+e[k].w)
{
d[v]=d[u]+e[k].w;
if(!inq[v])
{
inq[v]=true;
q.push(v);
}
}
}
}
}
void build_map()
{
int i;
memset(next,-1,sizeof(next));
memset(first,-1,sizeof(first));
for(i=0;i<qq;i++)
{
int u=e[i].u;
int v=e[i].v;
next[i]=first[v];
first[v]=i;
}

}
int main()
{
int t;
scanf("%d",&t);
int cas=0;
for(cas=0;cas<t;cas++)
{
scanf("%d%d",&p,&qq);
int i;
memset(first,-1,sizeof(first));
memset(next,-1,sizeof(next));
for(i=0;i<qq;i++)
{
scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
next[i]=first[e[i].u];
first[e[i].u]=i;
}
spfa1(1);
int sum=0;
for(i=2;i<=p;i++)
sum+=d[i];
build_map();
spfa2(1);
for(i=2;i<=p;i++)
sum+=d[i];
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: